PHPUnit on Ubuntu 12.04

This is what happens when you want to install PHPUnit on Ubuntu 12.04:

$ sudo apt-get install phpunit
$ phpunit
PHP Warning:  require_once(PHP/CodeCoverage/Filter.php): failed to open stream: No such file or directory in /usr/bin/phpunit on line 38
[...]


Workaround from John Faucett worked great, on the condition to update symphony url, as follow:

sudo apt-get remove phpunit
sudo apt-get upgrade pear
sudo pear channel-discover pear.phpunit.de
sudo pear channel-discover pear.symfony.com
sudo pear channel-discover components.ez.no
sudo pear update-channels
sudo pear upgrade-all
sudo pear install --alldeps phpunit/PHPUnit

(This bug has been reported)

 

Tags:

Share: